Stills Media - The issue with Phoenix, AZ (US-West) Datacenter has been resolved – Incident details
Get updates
Email
Slack
Microsoft Teams
Discord
Webhook
API
Get updates
All systems operational
The issue with Phoenix, AZ (US-West) Datacenter has been resolved
Resolved
Major outage
Started 10 days ago
Lasted 14 minutes
Updates
Resolved
Thursday, May 21, 2026 at 13:24 UCT
Resolved
Thursday, May 21, 2026 at 13:24 UCT
Our systems have reported that the issue with the Phoenix, AZ (US-West) Datacenter has been resolved.
Investigating
Thursday, May 21, 2026 at 13:10 UCT
Investigating
Thursday, May 21, 2026 at 13:10 UCT
Our system detected that Phoenix, AZ (US-West) Datacenter are reporting issues at the moment. We apologize for any inconvenience.