Stills Media - The issue with Phoenix, AZ (US-West) Datacenter has been resolved – Incident details
Get updates
Email
Slack
Microsoft Teams
Discord
Webhook
API
Get updates
All systems operational
The issue with Phoenix, AZ (US-West) Datacenter has been resolved
Resolved
Major outage
Started about 1 month ago
Lasted 2 minutes
Updates
Resolved
Wednesday, March 11, 2026 at 01:38 UCT
Resolved
Wednesday, March 11, 2026 at 01:38 UCT
Our systems have reported that the issue with the Phoenix, AZ (US-West) Datacenter has been resolved.
Investigating
Wednesday, March 11, 2026 at 01:36 UCT
Investigating
Wednesday, March 11, 2026 at 01:36 UCT
Our system detected that Phoenix, AZ (US-West) Datacenter are reporting issues at the moment. We apologize for any inconvenience.