Stills Media Systems Status - Biltmore Bathrooms DNS Propagation Issues – Incident details

All systems operational

Biltmore Bathrooms DNS Propagation Issues

Resolved
Major outage
Started 4 days agoLasted about 21 hours

Affected

Biltmore Bathrooms Platform

Operational from 12:30 AM to 8:47 PM, Degraded performance from 8:47 PM to 9:50 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    An update to the servers has been published and the DNS servers are recovering. We expect this to be fully resolved in about an hour.

  • Identified
    Identified

    Our systems detected an brief issue with the primary and secondary DNS servers causing a major service outage.