Stills Media - Phoenix AZ Datacenter Outage – Incident details

All systems operational

Phoenix AZ Datacenter Outage

Resolved
Major outage
Started 8 days agoLasted about 2 hours

Affected

Phoenix, AZ (US-West) Datacenter

Major outage from 11:00 PM to 12:18 AM, Operational from 12:18 AM to 12:32 AM, Major outage from 12:32 AM to 1:19 AM

Directory Management Application

Major outage from 11:00 PM to 12:18 AM, Operational from 12:18 AM to 12:32 AM, Major outage from 12:32 AM to 1:19 AM

Biltmore Church Specific Services

Major outage from 11:00 PM to 1:19 AM

Biltmore Church FOH Music Player

Major outage from 11:00 PM to 1:19 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We are still working with our 3rd party server management company to resolve this.

  • Identified
    Identified

    The server hosting the affected services is currently being targeted by a DDoS attack. We are awaiting updates from our 3rd party server management company.

  • Update
    Update

    We are still investigating this incident. Users are seeing increased latency and often times complete failure to load services. Standby for updates.

  • Investigating
    Investigating
    We are currently investigating this incident.